• Which version do I need to use with older MacOS X versions ?
    SwitchResX 4.3.6 is the last version compatible with Leopard, and the last one to support PowerPC.
    SwitchResX 3.8.7 is the last version compatible with Tiger.
    SwitchResX 3.5 is the last version compatible with Panther (provided you use version 10.3.9)